The popular open-source content management system WordPress will show a warning on the backend admin panel if the server the site is running on has an outdated PHP version.
This came as a surprise to WordPress users as the minimum PHP version needed to run WordPress hasn’t been changed for years.
The warnings are set to appear on sites using a PHP version lower than 5.6, that means any sites still running PHP version 5.5 and below will receive the warnings. Site owners will be shown a warning and a link to the WordPress support page along with info on how they can update their server’s PHP version.
The warnings will come and start appearing on sites with WordPress 5.1 that’s scheduled to be released this spring. The current and most stable WordPress version available right now is WordPress 5.0.
Only a small subset of WordPress users are expected to see the warning, as statistics compiled after the release of WordPress 5 showed at least 85% of all WordPress users are already running PHP versions 5.6 and newer.
The short-term goal of showing these warnings is to get as many WordPress users to update more recent PHP versions. This is so that the WordPress team can finally drop support for older PHP versions altogether because the WordPress team plans to officially modify the WordPress CMS minimum PHP version requirement from PHP 5.2 (the current) to PHP 5.6 by April 2019. (A similar minimum requirement version bump is also planned for MySQL, with MySQL 5.5 becoming the new minimum requirement.)
The long-term goal is to make PHP version 7.0 the minimum PHP version needed to run a WordPress site by December 2019.
The PHP team has recently dropped support for PHP 5.6.x and PHP 7.0.x versions. And servers still running older PHP versions are now vulnerable to attacks and exploits which is the main reason the WordPress team is pushing users to update their PHP version.
Image Source: Zdnet